http://i63.servimg.com/u/f63/13/63/39/68/sw4vhc11.jpg

منتديات صوت بلدنا
السلام عليكم
أهلا و سهلا بك في منتديات
صـوتـ بـلــدنــا
معلوماتنا تفيد بأنك غير مسجل أو لم تدخل اسم المستخدم الخاص بك
إذا أردت الدخول أو التسجيل تفضل من هنا ...


صوت بلدنا بني عبيد ميت فارس إسلاميات برامج دروس تعليم حماية شبكات اختراق هاك حوار جوال ألعاب ترفيه دعم تطوير دعاية إعلان ثقافة لغات أسرة مرأة طفل صحة رياضة إشهار سياسة أخبار قضايا قانون قصة شعر خواطر
الرئيسيةالتسجيل.:: البوابة ::.الإعلاناتبحـثدخول

شاطر | 
 

 أقوى سكربت لحماية الكاش في الميكروتك من الفيروسات و التروجان و الفيرس الصيني و الأوتورن 2010

استعرض الموضوع السابق استعرض الموضوع التالي اذهب الى الأسفل 
كاتب الموضوعرسالة

بيانات العضو

avatar
Super Admin
.:: ADM!N ::.
.:: ADM!N ::.

معلومات العضو

ذكر
المساهمات : 2341
العمر : 29
الموقع المفضل : صوت بلدنا فقط لا غير
العمل أو الوظيفة : محامي
المزاج : قشطة و الحمد لله
السٌّمعَة : 35
النقاط : : 47687
تاريخ التسجيل : 02/03/2009

معلومات الاتصال

http://sot-bladna.4ulike.com

الرجوع الى أعلى الصفحة اذهب الى الأسفل

 
مُساهمةموضوع: أقوى سكربت لحماية الكاش في الميكروتك من الفيروسات و التروجان و الفيرس الصيني و الأوتورن 2010   الإثنين 17 مايو 2010, 09:57

[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذه الصورة]




أقوى سكربت لحماية الكاش في الميكروتك من الفيروسات و التروجان و الفيرس الصيني و الأوتورن 2010


الأسكربت ده بيعمل تشيك يومي علي التروجانات الي بتنزل
من المواقع في ملفات
.html وخلافه

وبالتالي بتدخل في السيرفر وكمان بتبقي من نوع توزيع
الشبكة المحلية



وطريقة الإسكربت بالظبط كالتالي

1. نروح لـ System وبعدين Script
وبعدين Add

2.نعمل الأسم كده


3. في خانة الـSource




الكود:

   
:local date [/system clock get date]
:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local year [:pick $date 7 11]

#set month to numerical value
:if ([$month] = "jan") do={ :set month "01" }
:if ([$month] = "feb") do={ :set month "02" }
:if ([$month] = "mar") do={ :set month "03" }
:if ([$month] = "apr") do={ :set month "04" }
:if ([$month] = "may") do={ :set month "05" }
:if ([$month] = "jun") do={ :set month "06" }
:if ([$month] = "jul") do={ :set month "07" }
:if ([$month] = "aug") do={ :set month "08" }
:if ([$month] = "sep") do={ :set month "09" }
:if ([$month] = "oct") do={ :set month "10" }
:if ([$month] = "nov") do={ :set month "11" }
:if ([$month] = "dec") do={ :set month "12" }

#download current days domain list
/tool fetch address=www.epicwinrar.com host=www.epicwinrar.com mode=http src-path="conficker/$month-$day-$year.txt"
:log info "Download Complete"
:delay 2

#check to ensure todays file exists before deleting yesterdays list
:log info "Begining Address List Modification"
:if ( [/file get [/file find name="$month-$day-$year.txt"] size] > 0 ) do={

  /ip firewall address-list remove [/ip firewall address-list find list=daily-conficker]

  :local content [/file get [/file find name="$month-$day-$year.txt"] contents] ;
  :local contentLen [ :len $content ] ;

  :local lineEnd 0;
  :local line "";
  :local lastEnd 0;

  :do {
    :set lineEnd [:find $content "\n" $lastEnd ] ;
    :set line [:pick $content $lastEnd $lineEnd] ;
    :set lastEnd ( $lineEnd + 1 ) ;

#resolve each new line and add to the address list daily-conficker. updated to list domain as comment
      :if ( [:pick $line 0 1] != "\n" ) do={
        :local entry [:pick $line 0 ($lineEnd ) ]
        :if ( [:len $entry ] > 0 ) do={
            :local listip [:resolve "$entry"]
            :if ($listip != "failure" ) do={
              :if ((/ip firewall address-list find list=daily-conficker address=$listip) = "") do={
                /ip firewall address-list add list=daily-conficker address=$listip comment=$entry
                :log info "$listip"
            } else={:log info "duplicate IP $entry"}
          }
      }
  }
} while ($lineEnd < $contentLen)
}
:log info "Address List Modification Complete"
#cleaning up
/file remove "$month-$day-$year.txt" 






4. نعمل توقيت
للتشغيل نروح لـNew Terminal وناخد الكود Copy و Paste
الكود:

      
 /system scheduleradd comment="" disabled=no interval=1d name=Conficker-daily on-event="/system script run daily-conficker-list" start-date=jan/01/1970 start-time=00:00:01 

ودلوقتي بقي النتيجة




لو تحب تعرف الأجهزة المصابة
بالفيروس الي بتنشر نفسها علي الشبكة يبقي تركب الرول ده كمان








تروح لـNew Terminal


الكود:


       /ip firewall filteradd action=add-src-to-address-list address-list=conficker-infected address-list-timeout=1d chain=forward comment="label conficker-infected" disabled=no dst-address-list=  daily-conficker dst-port=80 protocol=tcp 


والأجهزة هتبقي موجوده في IP
>>> Firewall >>> Address List تحت مسمي daily-conficker


 الموضوع الأصلي : أقوى سكربت لحماية الكاش في الميكروتك من الفيروسات و التروجان و الفيرس الصيني و الأوتورن 2010 
المصدر :
مُنتَدَيَاتْ صُـوتــْ بَــلَــدْنََــا

______________________________________________________

Super Admin


الكل يريد القمة لكن القمة لا تريد إلا واحد.
التفكير من أكثر الأعمال صعوبة ... ولذلك فان القليلين يقومون به..
صوت بلدنا ,, مش مجرد منتدي !

 

 

أقوى سكربت لحماية الكاش في الميكروتك من الفيروسات و التروجان و الفيرس الصيني و الأوتورن 2010

استعرض الموضوع السابق استعرض الموضوع التالي الرجوع الى أعلى الصفحة 
صفحة 1 من اصل 1

صلاحيات هذا المنتدى:لاتستطيع الرد على المواضيع في هذا المنتدى
منتديات صوت بلدنا :: .:: قسم الحاسب و الإنترنت ::. :: .:: قسم الشبكات ::.-
© phpBB | انشئ منتدى | منتدى مجاني للدعم و المساعدة | إتصل بنا | التبليغ عن محتوى مخالف | انشئ مدونة مجانيا